互港财经

股通道资金主图

阅读量:169作者:股票量化研究所发布日期:06-11 09:38

这里发的指标均是通达信类型电脑版软件,手机软件有的可能不通用,我没是测试过。指标有设置参数的,新手不懂返回公众号菜单下面指标帮助或回复关键字指标帮助看教程。指标仅作分析参考,切勿当作神器。


说明:


1.数字资金图部分,总的来说,上部(横向)和下部(纵向)资金性质不同。上部是主力;下部是主动;

2.流入,流出资金,是主动,单位:万元;

3.DDE数据,是主力;

4.主力买占比=主力逐笔买入量/(主力逐笔买入量+主力逐笔卖出量)*100,单位是百分数;在通达信,主力逐笔就是主力,而非主动;

5.主力活跃度=(主力逐笔买入量+主力逐笔卖出量)/流通盘*100。单位是百分数;

6.主力净资=主力买入资金-主力卖出资金。单位是万元;

7.主主买比,就是主力主动买占比,是主力主动买资金占主力主动买资金与主力主动卖资金之和的比值,单位:%;

8.主力主动十红,是大宗流入十红;

9.从颜色上区分:红,蓝是主动;粉,绿是主力。

10.公式中用大量l2数据,没有开通的显示不全




例图:

股通道资金主图

股通道资金主图

指标源码:


DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,'H15',0);

DRAWBAND(MA(CLOSE,5),RGB(150,50,100),MA(CLOSE,10),RGB(83,123,68));

 

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1),LINETHICK0;

D:=SMA(K,3,1),LINETHICK0;

J:=3*K-2*D,LINETHICK0;

强弱界:MA(CLOSE,20),COLORCYAN,LINETHICK4;

上升趋势:IF(MA(CLOSE,20)>=REF(MA(CLOSE,20),1),MA(CLOSE,20),DRAWNULL),COLORMAGENTA,LINETHICK4;

{下降趋势:IF(MA(CLOSE,20)<REF(MA(CLOSE,20),1),MA(CLOSE,20),DRAWNULL),COLORCYAN,LINETHICK4;}

五日线:MA(CLOSE,5),LINETHICK3,COLORGREEN;

五日上升:IF(五日线>=REF(五日线,1),五日线,DRAWNULL),LINETHICK3,COLORRED;

 

十日线:MA(CLOSE,10),LINETHICK1,COLORWHITE;

生命线:MA(CLOSE,30),LINETHICK2,COLORRED;

六零线:MA(CLOSE,60),LINETHICK2,COLORWHITE;

{生命线:=EMA(CLOSE,20);}

STICKLINE(CLOSE>生命线 AND J>REF(J,1),OPEN,CLOSE,2,0),COLORRED;

STICKLINE(CLOSE>生命线 AND C>O AND J>REF(J,1),HIGH,LOW,0.1,0),COLORRED;

STICKLINE(CLOSE>生命线 AND C<O AND J>=REF(J,1),HIGH,LOW,0.05,0),COLORGREEN;

 

STICKLINE(CLOSE>生命线 AND J<REF(J,1),OPEN,CLOSE,2,0),COLORGRAY;

STICKLINE(CLOSE>生命线 AND C<O AND J<REF(J,1),HIGH,LOW,0.05,0),COLORGREEN;

STICKLINE(CLOSE>生命线 AND C>O AND {(J<K OR} J<REF(J,1),HIGH,LOW,0.05,0),COLORRED;

 

STICKLINE(CLOSE<生命线,OPEN,CLOSE,2,0),COLORGREEN;

STICKLINE(CLOSE<生命线 AND C>O,HIGH,LOW,0.05,0),COLORRED;

STICKLINE(CLOSE<生命线 AND C<O,HIGH,LOW,0.05,0),COLORGREEN;

{DRAWTEXTREL(5,20,STKLABEL+' '+STKNAME+' '+DYNAINFO(7)+'元'+' '+DYNAINFO(14)*100+'%'),LINETHICK2,COLORFFFF00;};

 

HD:=FI.TER(BACKSET(FI.TER(REF(C,10)=HHV(C,2*10+1),10),10+1),10);

LD:=FI.TER(BACKSET(FI.TER(REF(C,10)=LLV(C,2*10+1),10),10+1),10);

波峰:IF(BARSLAST(HD)<BARSLAST(LD) AND NOT(HD),REF(C,BARSLAST(HD)),REF(C,BARSLAST(HD))),COLORFF00FF,POI.TDOT;

波谷:IF(BARSLAST(HD)>BARSLAST(LD) AND NOT(LD),REF(C,BARSLAST(LD)),REF(C,BARSLAST(LD))),COLOR80FF00,POI.TDOT;

突破:=CROSS(C,波峰) AND VOL>MA(VOL,25) AND C/REF(C,1)>1.0143;

DRAWTEXT(突破,L*0.93,'突破'),COLORMAGENTA;

DRAWICON(突破,L*0.96,1);

 


 

VAR111:=ZIG(3,10);

DRAWICON((REF(VAR111,2) > REF(VAR111,1)) AND (VAR111 > REF(VAR111,1)),LOW*0.98,5);

DRAWTEXT((REF(VAR111,2) > REF(VAR111,1)) AND (VAR111 > REF(VAR111,1)),LOW*0.95,'全仓'),COLORYELLOW;

 

DRAWICON((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),HIGH*1.03,15);

DRAWTEXT((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),HIGH*1.06,'清仓'),COLORYELLOW;

 

{全仓画红色K线主体,清仓画蓝色K线主体。}

STICKLINE((REF(VAR111,2)>REF(VAR111,1)) AND (VAR111>REF(VAR111,1)),CLOSE,OPEN,4,0),COLORYELLOW;

STICKLINE((REF(VAR111,2)<REF(VAR111,1)) AND (VAR111<REF(VAR111,1)),CLOSE,OPEN,4,0),COLORBLUE;

{在小于等于3个交易日,符合黄笑脸和全仓条件时,在屏幕左上角显示红色“进场”;符合跑人和清仓条件时,显示黄色“离场”。线的粗细不起作用

{DRAWTEXT_FIX(CURRBARSCOUNT<=3 AND REF(VAR111,2) > REF(VAR111,1)

         AND VAR111 > REF(VAR111,1),0.00,0.28,0,'进场'),COLORRED;}

DRAWTEXT_FIX(CURRBARSCOUNT<=3 AND REF(VAR111,2) < REF(VAR111,1) AND VAR111 < REF(VAR111,1),0.00,0.28,0,'离场'),COLORYELLOW;

 

股价96:='Y395';

增幅96:=XMA(XMA(XMA(股价96,3),3),3)-REF(XMA(XMA(XMA(股价96,3),3),3),1);

X396:=XMA(股价96,3);

J396:=(XMA(股价96,3)*3+0.5*股价96-0.5*REF(股价96,1)+增幅96)/3;

Y396:IFF(CURRBARSCOUNT=1,J396,X396),LINETHICK4,COLORGREEN; 

IF(Y396>REF(Y396,1),Y396,DRAWNULL),COLORRED,LINETHICK4; 

高险区1:Y396*1.1,COLORLIRED,COLORFFFF00;

高风区2:Y396*1.125,COLORLIRED,COLORFF0000;

高风区3:Y396*1.15,COLORLIRED,COLOR00FF00;

良机区1:Y396*0.9,COLORLIBLUE,COLOR00FFFF;

良机区2:Y396*0.875,COLORLIBLUE,COLORFF00FF;

良机区3:Y396*0.85,COLOR0000FF;

 

JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));

DDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);

JJJT:=IF(DDD,1,(JJJ<(DYNAINFO(5)+0.01) && JJJ>(DYNAINFO(6)-0.01)));


{基础位移}

CYC∞:IF(JJJT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120)),COLORBLUE,LINETHICK2;

 

{基础位移}

CYS∞:=(CLOSE-CYC∞)/CYC∞*100;

成本谷:=REF(CYC∞,BARSLAST(CYS∞<=0)-1),LINETHICK0,COLORRED;{赋值指标为最近一次刚上穿CYC∞时的CYC∞的数值}

负成本谷:=REF(CYC∞,BARSLAST(CYS∞>0)-1);

正基础位移:=100*(CLOSE-成本谷)/成本谷;

负基础位移:=100*(CLOSE-负成本谷)/负成本谷;

基础位移:=IF(CYS∞>=0,正基础位移,负基础位移),LINETHICK0,COLORYELLOW;

牛天数:=BARSLAST(CROSS(CYS∞,0))+1;

熊天数:=(-1)*BARSLAST(CROSS(0,CYS∞))-1;

牛熊天数:=IF(CYS∞>0,牛天数,熊天数),LINETHICK0,COLORMAGENTA;

 

DRAWTEXT_FIX(1,0.004,0.360,0,STRCAT('成本谷:',CON2STR(成本谷,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.091,0.360,0,STRCAT('基础位移:',CON2STR(基础位移,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.180,0.360,0,STRCAT('牛熊天数:',CON2STR(牛熊天数,0))),COLORWHITE;

 

 

{以下LCY有较大修改}

超B:=L2_AMO(0,2)/10000.0;

大B:=L2_AMO(1,2)/10000.0;

中B:=L2_AMO(2,2)/10000.0;

小B:=L2_AMO(3,2)/10000.0;

超S:=-L2_AMO(0,3)/10000.0;

大S:=-L2_AMO(1,3)/10000.0;

中S:=-L2_AMO(2,3)/10000.0;

小S:=-L2_AMO(3,3)/10000.0;

净流入:=(超B+大B+中B+小B)+(超S+大S+中S+小S);

中单:=中B+中S;

大宗净流入:=(超B+大B)+(超S+大S);

三日大宗:=SUM(大宗净流入,3);

十日大宗:=SUM(大宗净流入,10);

超大单:=(超B)+(超S);

大单:=(大B)+(大S);

小单:=(小B)+(小S);

大宗进:=(超B)+(大B);

大宗出:=(超S)+(大S);

非大宗进:=(中B)+(小B);

非大宗出:=(中S)+(小S);

近3日流向:=SUM(净流入,3);

近10日流向:=SUM(净流入,10);

主力买力度:=LARGEI.TRDVOL*100/VOL;

主力卖力度:=LARGEOUTTRDVOL*100/VOL;

DRAWRECTREL(0,410,264,999.4,IF(120,RGB(10,0,0),0));

 

AAB:=CONST(MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单)))))*1.5,NODRAW;

DRAWRECTREL(2,CONST(945-(ABS(超大单)*400/AAB)),37,945,IF(CONST(超大单)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(39,CONST(945-(ABS(大单)*400/AAB)),74,945,IF(CONST(大单)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(76,CONST(945-(ABS(中单)*400/AAB)),111,945,IF(CONST(中单)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(113,CONST(945-(ABS(小单)*400/AAB)),148,945,IF(CONST(小单)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.002,0.9,0,I.TPART(超大单)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.038,0.85,0,I.TPART(大单)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.076,0.9,0,I.TPART(中单)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.115,0.85,0,I.TPART(小单)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.004,1,0,'超大单'),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.044,1,0,'大单'),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.082,1,0,'中单'),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1160,1,0,'小单'),COLORYELLOW;

 

AAC:=CONST(MAX(ABS(净流入),MAX(ABS(近3日流向),ABS(近10日流向))))*1.5,NODRAW;

DRAWRECTREL(153,CONST(945-(ABS(净流入)*400/AAC)),188,945,IF(CONST(净流入)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(190,CONST(945-(ABS(近3日流向)*400/AAC)),225,945,IF(CONST(近3日流向)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(227,CONST(945-(ABS(近10日流向)*400/AAC)),262,945,IF(CONST(近10日流向)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.152,0.9,0,I.TPART(净流入)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.190,0.85,0,I.TPART(近3日流向)),COLORWHITE;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.228,0.9,0,I.TPART(近10日流向)),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.152,1,0,'净流入'),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.190,1,0,'三日流'),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.228,1,0,'十日流'),COLORYELLOW;

 

DDX:=(LARGEI.TRDVOL-LARGEOUTTRDVOL)*100/CAPITAL;

DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);

DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);

DRAWRECTREL(2,415,88,465,IF(CONST(DDX)>0,RGB(175,50,250),RGB(0,100,0)));

DRAWRECTREL(89,415,175,465,IF(CONST(DDY)>0,RGB(175,50,250),RGB(0,100,0)));

DRAWRECTREL(176,415,262,465,IF(CONST(DDZ)>0,RGB(175,50,250),RGB(0,100,0)));

DRAWTEXT_FIX(1,0.004,0.420,0,STRCAT('大单动向:',CON2STR(DDX,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.091,0.420,0,STRCAT('涨跌动因:',CON2STR(DDY,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.178,0.420,0,STRCAT('大单差分:',CON2STR(DDZ,2))),COLORWHITE;

 

DDX连红:=BARSLASTCOUNT(DDX>0);

DDY连红:=BARSLASTCOUNT(DDY>0);

DDZ连红:=BARSLASTCOUNT(DDZ>0);

DRAWTEXT_FIX(1,0.004,0.470,0,STRCAT(STRCAT('连红  ',CON2STR(DDX连红,0)),' [天] ')),COLORWHITE;

DRAWTEXT_FIX(1,0.091,0.470,0,STRCAT(STRCAT('连红  ',CON2STR(DDY连红,0)),' [天] ')),COLORWHITE;

DRAWTEXT_FIX(1,0.178,0.470,0,STRCAT(STRCAT('连红  ',CON2STR(DDZ连红,0)),' [天] ')),COLORWHITE;

WWW70822COM:DRAWNULL,COLORRED;

DDX十红:=COUNT(DDX>0,10);

DDY十红:=COUNT(DDY>0,10);

DDZ十红:=COUNT(DDZ>0,10);

DRAWTEXT_FIX(1,0.004,0.520,0,STRCAT(STRCAT('十红  ',CON2STR(DDX十红,0)),' [天] ')),COLORWHITE;

DRAWTEXT_FIX(1,0.091,0.520,0,STRCAT(STRCAT('十红  ',CON2STR(DDY十红,0)),' [天] ')),COLORWHITE;

DRAWTEXT_FIX(1,0.178,0.520,0,STRCAT(STRCAT('十红  ',CON2STR(DDZ十红,0)),' [天] ')),COLORWHITE;

 

主买量占比:=LARGEI.TRDVOL/(LARGEI.TRDVOL+LARGEOUTTRDVOL)*100;

{主力净买量:=(LARGEI.TRDVOL-LARGEOUTTRDVOL);}

TMP:=LARGEI.TRDVOL-LARGEOUTTRDVOL;

主力活跃度:=(LARGEI.TRDVOL+LARGEOUTTRDVOL)*100/FINANCE(7)*100;

{主力活跃度:=(LARGEI.TRDVOL+LARGEOUTTRDVOL)*10000/(2*FINANCE(7));}

主力净资:=(L2_AMO(0,0)+L2_AMO(1,0)-L2_AMO(0,1)-L2_AMO(1,1))/10000.0;

DRAWRECTREL(2,570,88,616,IF(CONST(主买量占比)>50,RGB(175,50,250),RGB(0,100,0)));

DRAWRECTREL(89,570,175,616,IF(CONST(TMP)>0,RGB(175,50,250),RGB(0,100,0)));

DRAWRECTREL(176,570,262,616,IF(CONST(主力净资)>0,RGB(175,50,250),RGB(0,100,0)));

DRAWTEXT_FIX(1,0.004,0.575,0,STRCAT('主力买比:',CON2STR(主买量占比,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.091,0.575,0,STRCAT('主力活跃度:',CON2STR(主力活跃度,2))),COLORWHITE;

DRAWTEXT_FIX(1,0.178,0.575,0,STRCAT('主力净资:',CON2STR(主力净资,0))),COLORWHITE;

 

主力主动买占比:=(超B+大B)/(超B+大B-超S-大S)*100;

{主动买占比:=ACTINVOL/(ACTINVOL+ACTOUTVOL)*100;}

{连续飘红:=BARSLASTCOUNT(大宗净流入>0);}

十日飘红:=COUNT(大宗净流入>0,10);

DRAWRECTREL(2,616,88,665,IF(CONST(主力主动买占比)>50,RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(89,616,175,665,IF(CONST(十日飘红)>0,RGB(255,0,0),RGB(25,125,255)));

DRAWTEXT_FIX(1,0.004,0.620,0,STRCAT('主主买比:',CON2STR(主力主动买占比,2))),COLORYELLOW;

DRAWTEXT_FIX(1,0.091,0.620,0,STRCAT('主力主动十红:',CON2STR(十日飘红,0))),COLORYELLOW;

{分析家公式网 整理}

换手率:=VOL/CAPITAL*100,NODRAW,COLORRED; 

AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,换手率*240/FROMOPEN,DRAWNULL);{预测换手率}

DRAWRECTREL(175,616,262,665,IF(CONST(AA>=3 AND AA<15),RGB(255,0,0),RGB(25,125,255)));

{DRAWRECTREL(176,570,262,615,IF(CONST(主力净资)>0,RGB(175,50,250),RGB(0,100,0)));}

DRAWTEXT_FIX(1,0.178,0.620,0,STRCAT('预测换手:',CON2STR(AA,2))),COLORYELLOW;

 

DRAWNUMBER(ISLASTBAR  ,C,C),COLORWHITE;

 

股通道资金主图

长按二维码关注,更多精彩指标每天分享点赞点看能优先接收系统推送的图文消息。



相关资讯

评论

登录

忘记密码?

尚无账号?立即注册

注册

获取验证码
已有账号?

密码找回

获取验证码
已有账号?