互港财经

金钻道氏理论与通用指标MA搭建主图指标

阅读量:15824作者:股票量化研究所发布日期:02-06 15:44

这里发的指标均是通达信电脑版软件指标公式,手机软件有的可能不通用,但大部分通用,具体没测试过复制指标源码,新建粘贴到软件保存即可,不懂的公众号菜单看指标教程或回复关键字:指标帮助  。

指标说明:


主图指标,道氏理论做为一切技术分析的基石,从诞生到今天,已经经过了将近一个世纪的洗礼,其精髓至今仍然得以延续下来并为金融市场所验证。

下面就用道氏理论结合通用指标MA搭建自己的交易系统

道氏理论的基本法则
I.Tered="fI.Tered">一、平均指数包含一切,价格包容消化一切因素;
I.Tered="fI.Tered">可以这样认为,股票的走势包涵了一切因素『政治、经济政策,庄家动作,大众心理等。
I.Tered="fI.Tered">二、市场有三种趋势;
I.Tered="fI.Tered">趋势定义:上升趋势必须体现在依次上升的峰和谷上。相反,下降趋势则以依次下降的峰和谷为特征。(经典定义,是所有趋势分析的起点)
I.Tered="fI.Tered">这三种类型趋势的最大区别是时间的长短和波动幅度大小不同。
I.Tered="fI.Tered">趋势分成三类——主要趋势、次要趋势和短暂趋势(道氏用大海来比喻这三种趋势,把它们分别对应于潮汐、浪涛和波纹)横向延伸的波动常常出现在调整状态中,也可以在顶部或底部的反转过程中见到,在现代术语中,这种形态称为矩形。
I.Tered="fI.Tered">1、主要趋势(大趋势),通常持续一年以上,有时甚至好几年。;
I.Tered="fI.Tered">牛市中“主要趋势”也就是上升趋势,熊市中“主要趋势”指的就是下跌趋势了。
I.Tered="fI.Tered">2、次要趋势(三个星期到三个月,调整位通常为先前趋势运动的三分之一至三分之二,最常见的为百分之五十);
I.Tered="fI.Tered">上涨趋势中的“回调”,下跌趋势中的“反弹”,一言以蔽之和主要趋势相反的小波动。
I.Tered="fI.Tered">3、短暂趋势(或小趋势)通常持续不到三个星期,是趋势中较短线的波动。
I.Tered="fI.Tered">三、主要趋势分为三个阶段,大趋势可分为三个阶段;
I.Tered="fI.Tered">  1、收集阶段(经过一轮大的下跌,市场“利空”消息不断,价格开始企稳,机敏的投资者开始买入);主力吸筹(股票)阶段
I.Tered="fI.Tered">2、公众参与阶段(价格加速上扬,消息开始转好,大多数技术型趋势追随者开始参与);
I.Tered="fI.Tered">3、派发阶段(所有报刊开始刊登看涨故事时,所有人投身市场时,机敏的投资者开始卖出),也就是主力卖出阶段。
I.Tered="fI.Tered">四、各种平均指数必须相互验证;
I.Tered="fI.Tered">如果某个趋势符合道氏理论,那么整个市场的各种指数都必须相互间都印证、符合道氏理论的基本法则,只要有一个指数走势不印证道氏理论的基本法则,那么主要趋势已经改变的判断不成立。比如现在国内如果有10个指数,那么这10个指数(深成指数、上证指数、300指数……)都必须印证趋势的改变。

五、成交量必须印证趋势;
I.Tered="fI.Tered">1、上升趋势中,成交量伴随上涨而增加,下跌而减少;
I.Tered="fI.Tered">2、下降趋势中,成交量伴随下跌而增加,上涨而减少。

六、趋势在给出明确的反转信号之前被假定一直有效,唯有发生了确凿无疑的反转信号之后,才能判断一个既定的趋势已经终结;

  注:这句话的原意是“趋势在没有被打破的时候,它会一直延续下去”。注意,这句话看似废话,但里面的玄机,认真思考的话,会让人受益匪浅。实际交易中,大部分让人困惑的东西,这句话全包括在内了。该怎么做,也都在这句话里头。

1、失效摆动;
I.Tered="fI.Tered">高点C挑战高点A失败,随后市场跌破低点B,构成了在点S处的“卖出信号”。

2、非失效摆动。
I.Tered="fI.Tered">高点C突破高点A,随后市场跌破低点B构成S1处的第一个“卖出信号”,接着市场反弹到高点E,最后跌破低点D构成S2处的第二个“卖出信号”。


指标例图:


金钻道氏理论与通用指标MA搭建主图指标



金钻道氏理论与通用指标MA搭建主图指标

指标源码:



长期趋势250日线:MA(CLOSE,250),COLORBROWN;中长趋势120日线:MA(CLOSE,120),COLORLIGRAY;中期趋势60日线:MA(CLOSE,60),COLORGREEN;短期趋势20日线:MA(CLOSE,20),COLORMAGENTA;MA5:MA(CLOSE,5),COLORWHITE;IF(MA5>REF(MA5,1),MA5,DRAWNULL),COLORRED;MA10:MA(CLOSE,10),COLORYELLOW;IF(MA10>REF(MA10,1),MA10,DRAWNULL),COLORRED;MA20:MA(CLOSE,20),COLORMAGENTA;IF(MA20>REF(MA20,1),MA20,DRAWNULL),COLORRED;MA60:MA(CLOSE,60),COLORGREEN;IF(MA60>REF(MA60,1),MA60,DRAWNULL),COLORRED;MA120:MA(CLOSE,120),COLORLIGRAY;IF(MA120>REF(MA120,1),MA120,DRAWNULL),COLORRED;MA250:MA(CLOSE,250),COLORBROWN,LINESTICK;IF(MA250>REF(MA250,1),MA250,DRAWNULL),COLORRED;STICKLINE(C<=MA250,H,L,3,0),COLORBLACK;DRAWTEXT_FIX(N,0,0.01,0,'道氏理论的基本法则');DRAWTEXT_FIX(N,0,0.04,0,'一、平均指数包含一切,价格包容消化一切因素;可以这样认为,股票的走势包涵了一切因素『政治、经济政策,庄家动作,大众心理等。'),COLORYELLOW;DRAWTEXT_FIX(N,0,0.07,0,'二、市场有三种趋势;趋势定义:上升趋势必须体现在依次上升的峰和谷上。相反,下降趋势则以依次下降的峰和谷为特征。(经典定义,是所有趋势分析的起点)'),COLORYELLOW;DRAWTEXT_FIX(N,0,0.1,0,'更多用法请看指标注释'),COLORGREEN;DRAWTEXT_FIX(N,0,0.13,0,'不想看主图提示,请把参数N调成0'),COLORGREEN;DRAWICON(CROSS(MA5,MA10),MA10,1);DRAWICON(CROSS(MA10,MA5),MA5,2);





关注我更多新指标新经验免费分享大家......金钻道氏理论与通用指标MA搭建主图指标

关注我更多新指标新经验免费分享大家......

关注我更多新指标新经验免费分享大家......

关注我更多新指标新经验免费分享大家......



相关资讯

评论

登录

忘记密码?

尚无账号?立即注册

注册

获取验证码
已有账号?

密码找回

获取验证码
已有账号?