互港财经

三色出彩副图+选股

阅读量:416作者:股票量化研究所发布日期:07-17 10:40

这里发的指标均是通达信类型电脑版软件,手机软件有的可能不通用,我没是测试过。指标有设置参数的,新手不懂返回公众号菜单下面指标帮助或回复关键字指标帮助看教程。指标仅作分析参考,切勿当作神器。


说明:


出现三色柱子是介入信号,相对应的这个信号做了选股


例图:


三色出彩副图+选股

三色出彩副图+选股


指标源码:


N:=9;M1:=3;M2:=3;

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K:=SMA(RSV,M1,1);

D:=SMA(K,M2,1);

J:=3*K-2*D;

钝化:=IF(COUNT(K<20,3)=3,10,DRAWNULL) AND IF(COUNT(K<20,1)=1,10,DRAWNULL);

红:=COUNT(钝化,3)>=2;

MA1:=EMA(CLOSE,8);

趋势线:=(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1);

GUA1:=((CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)>=REF(CLOSE,2)) AND (REF(CLOSE,1)<=REF(CLOSE,3)) AND (REF(CLOSE,2)<=REF(CLOSE,3)) AND ((REF(CLOSE,4)>REF(CLOSE,2)) OR (REF(CLOSE,4)<=REF(CLOSE,2)) AND (REF(CLOSE,5)>=REF(CLOSE,3))) OR (CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)<=REF(CLOSE,2))

AND (CLOSE>=REF(CLOSE,2)) AND ((REF(CLOSE,3)>REF(CLOSE,1)) OR(REF(CLOSE,3)<=REF(CLOSE,1)) AND (REF(CLOSE,4)>=REF(CLOSE,2))));

GUB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);

GUB3:=EMA(GUB2,7);

GUB4:=EMA(GUB3,10);

GUB5:=(3)*(GUB3)-(2)*(GUB4);

GUB6:=EMA(GUB5,5);

底部:=IF((趋势线<=5),58,0),COLORFF00FF;

串:=EMA(GUB6,1);

黄:=串 AND IF(REF((COUNT((串<=REF(串,1)),5)=5),1) AND (串>REF(串,1)),10,0);

P1:=3;

P2:=3;

RSSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

KS:=SMA(RSSV,3,1),COLORYELLOW;

DS:=SMA(KS,3,1),COLOR00DD00;

蓝:=FI.TER(CROSS(KS,DS) AND KS<20,4);

出彩:=红 AND 黄 AND 蓝;

STICKLINE(出彩,0,75,2,0),COLORWHITE;

STICKLINE(出彩,52,73,1.2,0),COLORRED;

STICKLINE(出彩,27,48,1.2,0),COLORYELLOW;

STICKLINE(出彩,2,23,1.2,0),COLORBLUE;



三色选股指标:


N:=9;M1:=3;M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
钝化:=IF(COUNT(K<20,3)=3,10,DRAWNULL) AND IF(COUNT(K<20,1)=1,10,DRAWNULL);
红:=COUNT(钝化,3)>=2;
MA1:=EMA(CLOSE,8);
趋势线:=(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1);
GUA1:=((CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)>=REF(CLOSE,2)) AND (REF(CLOSE,1)<=REF(CLOSE,3)) AND (REF(CLOSE,2)<=REF(CLOSE,3)) AND ((REF(CLOSE,4)>REF(CLOSE,2)) OR (REF(CLOSE,4)<=REF(CLOSE,2)) AND (REF(CLOSE,5)>=REF(CLOSE,3))) OR (CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)<=REF(CLOSE,2))
AND (CLOSE>=REF(CLOSE,2)) AND ((REF(CLOSE,3)>REF(CLOSE,1)) OR(REF(CLOSE,3)<=REF(CLOSE,1)) AND (REF(CLOSE,4)>=REF(CLOSE,2))));
GUB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
GUB3:=EMA(GUB2,7);
GUB4:=EMA(GUB3,10);
GUB5:=(3)*(GUB3)-(2)*(GUB4);
GUB6:=EMA(GUB5,5);
底部:=IF((趋势线<=5),58,0),COLORFF00FF;
串:=EMA(GUB6,1);
黄:=串 AND IF(REF((COUNT((串<=REF(串,1)),5)=5),1) AND (串>REF(串,1)),10,0);
P1:=3;
P2:=3;
RSSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KS:=SMA(RSSV,3,1),COLORYELLOW;
DS:=SMA(KS,3,1),COLOR00DD00;
蓝:=FI.TER(CROSS(KS,DS) AND KS<20,4);
出彩:红 AND 黄 AND 蓝;


三色出彩副图+选股

长按二维码关注,更多精彩指标每天分享点赞点看能优先接收系统推送的图文消息。



相关资讯

评论

登录

忘记密码?

尚无账号?立即注册

注册

获取验证码
已有账号?

密码找回

获取验证码
已有账号?