互港财经

波段四种背离指标

阅读量:935作者:股票量化研究所发布日期:07-27 09:50

这里发的指标均是通达信类型电脑版软件,手机软件有的可能不通用,我没是测试过。指标有设置参数的,新手不懂返回公众号菜单下面指标帮助或回复关键字指标帮助看教程。指标仅作分析参考,切勿当作神器。


说明:


1、红色柱主升作多,绿色柱做空

2、添加了常用的指标底部和顶部背离提示


例图:

波段四种背离指标


波段四种背离指标


指标源码:



SJ:=1;

严重超买:100*SJ,COLORRED,DOTLINE;

超买:80,COLORRED,DOTLINE;

超卖:20,COLOR00FF00,DOTLINE;

严重超卖:0*SJ,COLOR00FF00,DOTLINE;

MACD顶背:0,COLOR00FF00;

MACD底背:0,COLORRED;

KDJ顶背:0,COLORFFCC66;

KDJ底背:0,COLORFF00FF;

RSI顶背:0,COLORFFFFFF;

RSI底背:0,COLORYELLOW;

DMI顶背:0,COLORBLUE;

DMI底背:0,COLOR0099FF;

TRR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);

HD := HIGH-REF(HIGH,1);

LD := REF(LOW,1)-LOW;

PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);

MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);

PDI:= PDM*100/TRR;

MDI:= MDM*100/TRR;

A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1))*SJ;

B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9))*SJ;

A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3))*SJ;

A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24))*SJ;

C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));

D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9))*SJ;

C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));

D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3))*SJ;

C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));

D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24))*SJ;

C4:=BARSLAST(REF(CROSS(MDI,PDI),1));

D4:=REF(C,C+1)<C AND REF(MDI,C4+1)>MDI AND CROSS(MDI,PDI);

A4:=BARSLAST(REF(CROSS(PDI,MDI),1));

B4:=REF(C,A4+1)>C AND REF(PDI,A4+1)<PDI AND CROSS(PDI,MDI);

DRAWTEXT(B4>0,5,'DMI底背'),COLOR0099FF;

DRAWTEXT(D4>0,95,'DMI顶背'),COLORBLUE;

DRAWTEXT(B1>0,15,'MACD底背'),COLORRED;

DRAWTEXT(B2>0,10,'KDJ底背')*SJ,COLORFF00FF;

DRAWTEXT(B3>0,18,'RSI底背')*SJ,COLORYELLOW;

DRAWTEXT(D1>0,85,'MACD顶背')*SJ,COLOR00FF00;

DRAWTEXT(D2>0,90,'KDJ顶背')*SJ,COLORFFCC66;

DRAWTEXT(D3>0,96,'RSI顶背')*SJ,COLORFFFFFF;

STICKLINE(B1>0,20,0,0,0),COLORRED;

STICKLINE(B2>0,20,0,0,0),COLORFF00FF;

STICKLINE(B3>0,20,0,0,0),COLORYELLOW;

STICKLINE(D1>0,80,100,0,0),COLOR00FF00;

STICKLINE(D2>0,100,80,0,0),COLORFFCC66;

STICKLINE(D3>0,100,80,0,0),COLORWHITE;

STICKLINE(B4>0,20,0,0,0),COLOR0099FF;

STICKLINE(D4>0,100,80,0,0),COLORBLUE;

VAR188:=((CLOSE - LLV(LOW,34))/(HHV(HIGH,34) - LLV(LOW,34)))*(100);

VAR288:=REVERSE(VAR188);

VAR388:=SMA(VAR188,9,1);

K88:=SMA(VAR388,3,1)*SJ;

D88:=SMA(K88,3,1)*SJ;

STICKLINE((K88 >= D88),K88,D88,1,0),COLOR0000FF;

STICKLINE((K88 <= D88),K88,D88,1,0),COLOR00FF00;


波段四种背离指标

长按二维码关注,更多精彩指标每天分享点赞点看能优先接收系统推送的图文消息。



相关资讯

评论

登录

忘记密码?

尚无账号?立即注册

注册

获取验证码
已有账号?

密码找回

获取验证码
已有账号?